Une Bue wrote:
> i wanted to test wxRuby with the simplest script :

As the wiki states, it's better to start with the samples bundled with 
wxruby. Many of the examples on the wiki are dated.

On OS X, you can find the samples that installed with the gem at:

/System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/user-gems/1.8/gems/wxruby-1.9.5-universal-darwin-9/samples/


basically you want just

require "rubygems"
require "wx"

at the start of your script.

> I've installed "wxruby-1.9.3-universal-darwin"

the latest gem version is 1.9.6; I recommend you install that.

There are dedicated mailing lists for wxruby questions:
http://wxruby.rubyforge.org/wiki/wiki.pl?MailingLists

alex