i've a cgi wanted to make use of yaml and i get this error reported by
Apache2 :

[Tue May 06 12:25:50 2008] [error] mod_ruby: error in ruby
[Tue May 06 12:25:50 2008] [error] mod_ruby:
/opt/local/lib/ruby/1.8/yaml.rb:133:in `load': syntax error on line 3,
col -1: `    manpath: "" (ArgumentError)
[Tue May 06 12:25:50 2008] [error] mod_ruby:     search: man
[Tue May 06 12:25:50 2008] [error] mod_ruby:     section: ""
[Tue May 06 12:25:50 2008] [error] mod_ruby:   : 1
[Tue May 06 12:25:50 2008] [error] mod_ruby: 
[Tue May 06 12:25:50 2008] [error] mod_ruby: yaml:
/Users/yt/Sites/man/man_rep/history.yaml
[Tue May 06 12:25:50 2008] [error] mod_ruby: '
[Tue May 06 12:25:50 2008] [error] mod_ruby:   from
/opt/local/lib/ruby/1.8/yaml.rb:133:in `load'
[Tue May 06 12:25:50 2008] [error] mod_ruby:   from
/Users/yt/Sites/man/index.rbx:30
[Tue May 06 12:25:50 2008] [error] mod_ruby:   from
/opt/local/lib/ruby/1.8/apache/ruby-run.rb:53:in `load'
[Tue May 06 12:25:50 2008] [error] mod_ruby:   from
/opt/local/lib/ruby/1.8/apache/ruby-run.rb:53:in `handler'


the calling line being :
 history=YAML::load( File.open( YAMLFILE ) )

and the yaml file being no more than :
--- history.yaml ------------------------------
--- !ruby/object:History 
items: 
  !ruby/object:Item ? 
    manpath: ""
    search: man
    section: ""
  : 1

yaml: /Users/yt/Sites/man/man_rep/history.yaml
--- history.yaml ------------------------------


I should mention i don't have prob when testing that apart from Apache2
and cgi.

When testing under Apache2/cgi my requirements are :
require 'rubygems'
require 'cgi'
require 'fileutils'
require 'yaml'
require 'history'


When testing standalone:
require 'rubygems'
require 'yaml'
require 'history'


the 'history' script being a class History of mine, nothing to do (i
believe) with the prob.

-- 
Une B?vue