On Apr 29, 2008, at 13:07 PM, jOhn wrote:

> Ok enough of my rant.  I had to clean and clean.
>
> Just note:
>
> [...] rubygems 1.1.1 is not backward compatible

Why would you expect a 1.x release to be fully backwards compatible  
with a 0.x release?

If you are referring specifically to #require_gem, it was deprecated  
in favor of #gem  with RubyGems 0.9.0 which was released late June  
2006.  The RubyGems maintainers made a Big Deal about the change on  
this mailing list at the time.

Rails 1.1.6 was released a couple months later, so perhaps we didn't  
make a Big Enough deal about it, or perhaps the Rails maintainers had  
a good reason not to make the switch to #gem (to fit in with their  
versioning scheme, insufficient testing, etc.).

Still, I think 18 months of deprecation of a feature before removal is  
plenty.