From: Hidetoshi NAGAI <nagai / ai.kyutech.ac.jp>
Subject: Re: How can install Tk8.5 to Ruby1.8.6
Date: Wed, 30 Apr 2008 00:32:47 +0900
Message-ID: <20080430.003248.74726011.nagai / ai.kyutech.ac.jp>
> Probably, tcltklib on one-click-ruby is compiled for Tcl/Tk8.4 only. 
> You must make tcltklib.so (ext/tk/tcltklib.c) with Tcl/Tk8.5.
> Or, use --enable-tcltkstubs option and make with Tcl/Tk8.4. 
> It may work with any of Tcl/Tk8.4 or 8.5. 
> Please read "ext/tk/README.tcltklib" about configure options.

I recommend to try Ruby 1.8.7 (or ruby_1_8 on SVN), 
or replace "ext/tk" directory to the one of Ruby 1.8.7.
It has many changes to support Tcl/Tk8.5.
-- 
Hidetoshi NAGAI (nagai / ai.kyutech.ac.jp)