Dear all,

I am having trouble installing/using RMagick on Ubuntu Gutsy (7.10) Linux.
I tried various ways, and finally managed to get the installation process
to complete "successfully" for the RMagick gem 2.3.0, after installing
both ImageMagick and GraphicsMagick via the apt-get install process,
along with several of the prerequisite libraries for the various graphics
formats.

When trying some examples, (like the cropping example on the
transformation page),
 I get this error:

$ruby rone.rb
/var/lib/gems/1.8/gems/rmagick-2.3.0/lib/RMagick2.so: /var/lib/gems/1.8/gems/rmagick-2.3.0/lib/RMagick2.so: undefined symbol: SketchImage - /var/lib/gems/1.8/gems/rmagick-2.3.0/lib/RMagick2.so (LoadError)
        from /usr/lib/ruby/1.8/rubygems/custom_require.rb:32:in `require'
        from /var/lib/gems/1.8/gems/rmagick-2.3.0/lib/RMagick.rb:11
        from /usr/lib/ruby/1.8/rubygems/custom_require.rb:32:in `gem_original_require'
        from /usr/lib/ruby/1.8/rubygems/custom_require.rb:32:in `require'
        from rone.rb:2


Now, I've read in the documentation that apparently, some other
library libMagickGraphicsWand.so is sought. It's there, it's found,
but Rmagick still won't work ...

#ldconfig -p | grep Magick 

	libMagick.so.10 (libc6) => /usr/local/lib/libMagick.so.10
	libMagick.so.9 (libc6) => /usr/lib/libMagick.so.9
	libMagick.so (libc6) => /usr/local/lib/libMagick.so
	libMagick.so (libc6) => /usr/lib/libMagick.so
	libMagick++.so.10 (libc6) => /usr/local/lib/libMagick++.so.10
	libMagick++.so (libc6) => /usr/local/lib/libMagick++.so
	libGraphicsMagickWand.so.0 (libc6) => /usr/lib/libGraphicsMagickWand.so.0
	libGraphicsMagick.so.1 (libc6) => /usr/lib/libGraphicsMagick.so.1

What can I do ?

Thank you very much,

Axel 
-- 
Psssst! Schon vom neuen GMX MultiMessenger geh÷˛t?
Der kann`s mit allen: http://www.gmx.net/de/go/multimessenger