My Ubuntu's ruby, too, didn't come installed with ruby-tk. I used my 
package manager to install it. Your package manager is 'yum', I think. 
Have you tried somethng along of 'yum install ruby-tk' ?
-- 
Posted via http://www.ruby-forum.com/.