Hello,

I was struggling with the same problem for about two days.
The final solution was installing ruby-zlib and then reinstalling 
rubygems from source. Dunno why...

This is quite strange, because my ruby version is 1.8.6, gem version 
1.1.0, zlib and zlib-devel were installed before the installation of 
ruby & rubygems.

But after I've installed ruby and rubygems from source I was haunted by 
this error when I tried to install rails. (gem i rails 
--include-dependencies)

/usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in
`gem_original_require': no such file to load -- zlib (LoadError)

This solved my zlib LoadError issue:

wget http://www.blue.sky.or.jp/atelier/ruby/ruby-zlib-0.6.0.tar.gz
tar xvzf ruby-zlib-0.6.0.tar.gz
cd ruby-zlib-0.6.0
ruby extconf.rb && make && make install

(and reinstall your rubygems from source)

Have a nice day,


Lukas Rieder
-- 
Posted via http://www.ruby-forum.com/.