I have installed my ruby/rails development environment according to
Dan's wonderful write-up over at Hivelogic (Thanks Dan!!):

http://hivelogic.com/articles/ruby-rails-leopard/

I'm now trying to install Ruby 1.9 in the same manner. Everything goes
swell until "sudo make install", in which I get the error below. Anybody
know what's wrong? (Please note that I'm just following Dan's write-up
and have little knowledge.)

./miniruby  ./instruby.rb --dest-dir="" --extout=".ext" --make="make"
--mflags="" --make-flags="" --installed-list .installed.list
--mantype="doc"
installing binary commands
/usr/local/src/ruby-1.9.0-0/lib/fileutils.rb:787:in `size': No such file
or directory - ruby (Errno::ENOENT)
  from /usr/local/src/ruby-1.9.0-0/lib/fileutils.rb:787:in
`compare_file'
  from /usr/local/src/ruby-1.9.0-0/lib/fileutils.rb:835:in `block in
install'
  from /usr/local/src/ruby-1.9.0-0/lib/fileutils.rb:1392:in `block in
fu_each_src_dest'
  from /usr/local/src/ruby-1.9.0-0/lib/fileutils.rb:1406:in
`fu_each_src_dest0'
  from /usr/local/src/ruby-1.9.0-0/lib/fileutils.rb:1390:in
`fu_each_src_dest'
  from /usr/local/src/ruby-1.9.0-0/lib/fileutils.rb:834:in `install'
  from ./instruby.rb:99:in `install'
  from ./instruby.rb:192:in `block in <main>'
  from ./instruby.rb:362:in `call'
  from ./instruby.rb:362:in `block (2 levels) in <main>'
  from ./instruby.rb:359:in `each'
  from ./instruby.rb:359:in `block in <main>'
  from ./instruby.rb:358:in `each'
  from ./instruby.rb:358:in `<main>'
make: *** [do-install-nodoc] Error 1
-- 
Posted via http://www.ruby-forum.com/.