>   sudo gem install dbus

Well after all of that, I can't compile the dbus gem unless I download 
and compile the newest version of the real dbus (because the deb is 
still out of date).  Interfering with my deb's is not something I like 
doing because of updates, so I guess I'll just have to wait.

Maybe Hardy Heron will solve my problems.

If Ruby just had system threading this would not even be an issue.  Once 
again, I guess I will just have to wait.
-- 
Posted via http://www.ruby-forum.com/.