On Feb 27, 1:06 pm, Ad Ad <codetest... / gmail.com> wrote:
> Hi,
> I am trying to access MySQL 5.0 using the mysql.rb got from:http://raa.ruby-lang.org/project/ruby-mysql/
>
> Apparently, this client is pre 4.1 and can't be used to access MySQl
> 5.0.
>
> I get this error while trying to access the database:
> Client does not support authentication protocol requested by server;
> consider upgrading MySQL client
>
> Is there a latest mysql client version which I can use to access MYSQl
> 5.0?
>
> I am on a Windows XP box.
>

Have you tried install the mysql gem?

gem install mysql

Please refer to the RubyForge project page:

http://rubyforge.org/projects/mysql-win/

HTH,
--
Luis Lavena