Can you try with require 'rubygems' before your require 'rubyzip' ?

Thanks