On Feb 8, 2008 2:20 AM, Dejan Dimic <dejan.dimic / gmail.com> wrote:
> I am using:
> Eclipse: Version: 3.3.1.1 Build id: M20071023-1652
> Subclipse: version 1.2.4
> Apatana PlugIn
> RadRails 0.8.0.200707021211

What's Apatana?

> and haven't encounter that kind of problems.
> Does it malfunction regarding requiring your files or in general?
> Perhaps you should use require File.expand_path(File.dirname(__FILE__)
> + your_file_relative_path).

It complains about not being able to find the file. We're using some
init stuff that looks similar to that, but eclipse thinks it can't
find those, either. When I hand-add what you suggested, it works.
But... I shouldn't have to change my code to adapt to my IDE. That's
ridiculous. Does this maybe indicate that eclipse doesn't... know
where it is, sort of? Could it have to do with the fact that I added
the .project and .loadpath to the SVN repository's ignore list? That
doesn't seem to make sense.

Thanks for your suggestion, but I guess I'm still looking for the
setting I need to twiddle to fix this.


Ben