On Thu, 2008-01-31 at 08:14 +0900, Eric Hodel wrote:
> Instead of calling #gem, you can rb_funcall require instead.

Strange, I tried that but it didn't find the json gem. I tried with both

   rb_require("rubygems");
   rb_funcall(rb_mKernel, rb_intern("require"), 1, rb_str_new2("json"));

and

   rb_funcall(rb_mKernel, rb_intern("require"), 1,
rb_str_new2("rubygems"));
   rb_funcall(rb_mKernel, rb_intern("require"), 1, rb_str_new2("json"));

I'm using ruby 1.8.6 (2007-09-23 patchlevel 110).

Andre