John Joyce wrote:
> On Jan 26, 2008, at 3:29 PM, 7stud -- wrote:
> 
>>> /usr/lib/ruby/gems/1.8/gems/rubygems-update-1.0.1
>> couldn't be found.   But the update program that was downloaded is
>> There is no file named rubygems-update-1.0.1, and why should there be
>> when the message says that rubygems-update-1.0.0 is what was
>> "installed".
>>
>> -- 
>> Posted via http://www.ruby-forum.com/.
>>
> Ok, then first do this:
> gem -v
> find out what version you've got now.
> Should be 1.0.0
> right?

No.  I have version:

$ gem -v
0.9.4


> If not, go into rubygems-update-1.0.0
> it is a directory.
> there is a readme in there check what's in it. You might need to do
> something with stuff in there first, then run the update again...

The readme just directs me to various places on the rubygems website 
e.g. installation, faq, which I've already looked at.


> or perhaps one of the paths was wrong in the updater? (wrong for your
> system)

That's what I think.


> You might need to set an explicit path for the updater.
> You might even need to do a manual update.
> None the less, the latest version should be 1.0.1
> I had 6.x or 7.x before updating it myself recently.
> I had Ruby 1.8.4 for a long time too.
> Then recently, some gems were giving errors, so I updated things and
> everything is working better.

I guess I'll install ruby 1.8.6 and go from there since it's not really 
fair to ask people to spend a lot of time trying to fix installation 
problems for old versions.  Thanks for your help.  I appreciate it.



-- 
Posted via http://www.ruby-forum.com/.