On Jan 17, 2008, at 7:45 AM, Len Lawrence wrote:

> Just to close the lid on this.  Lyle offered some very valuable
> suggestions about upgrading.  The final problem was solved by  
> placing the
> statement:
>
>   require 'rubygems'
>
> at the beginning of the script.  This did not appear in the book  
> example
> presumably because its inclusion was to be understood.  With that  
> change
> the fox16 object was found and loaded.  All is well, apart from my  
> blushes.

No blushes necessary. I've added a sidebar for the next release of  
the beta book that talks about RubyGems configuration and addresses  
this problem.