I figured out...needed the eruby library....

Mikkel


----- Original Message -----
From: "Mikkel Bruun" <mikkel / increment.dk>
To: "ruby-talk ML" <ruby-talk / ruby-lang.org>
Sent: Friday, December 14, 2001 7:48 PM
Subject: [ruby-talk:28537] WeBrick 1.0.0 error


> Hi guys,
>
> It ran perfect on my win box....but on my linux it crashes...
>
> Im trying to run the httpd.rb sample and I have triede diffrrent ports....
>
> Im running ruby 1.6.5 and i get the following:
>
> cannot load `erb/erbl'[2001-12-14 21:02:42] INFO  Logging start (level=5).
> ../../lib/webrick/server.rb:61:in `new': Invalid argument - "socket(2)"
> (Errno::EINVAL)
>         from ../../lib/webrick/server.rb:61:in `listen'
>         from ../../lib/webrick/server.rb:60:in `each'
>         from ../../lib/webrick/server.rb:60:in `listen'
>         from ../../lib/webrick/server.rb:51:in `initialize'
>         from ../../lib/webrick/httpserver.rb:25:in `initialize'
>         from ./httpd.rb:12:in `new'
>         from ./httpd.rb:12
>
> thanks
>
> Mikkel
>
>