Michael Greenly wrote:
> . . . .
> 
> I just made a blog post about running all three side by side that may 
> help
> also.
> 
> http://blog.michaelgreenly.com/2007/12/multiple-ruby-version-on-ubuntu.html

Thanks so much.  In the meantime I had solved it for my purposes.

1) sudo apt-get install --reinstall zlib1g zlib1g-dev
2) in ~/ruby-1.8.6/ __ sudo ./configure; sudo make; sudo make install
3) in ~/rubygems-1.0.1/ __ sudo ruby setup.rb

ruby -v returns 1.8.6
gem -v returns 1.0.1

sudo gem update --system __ works
sudo gem install rails __ works

Yay !



-- 
Posted via http://www.ruby-forum.com/.