On Fri, Dec 28, 2007 at 10:27:55AM +0900, Jesse Crockett wrote:
>
>same problems after apt installing zlib1g-dev
>
>results: http://pastie.caboo.se/132604
>
>further, I installed Ruby and Gems from source (I believe) ...


If you didn't have the -dev zlib package installed when you compiled
Ruby from source, the Ruby zlib extension can't have been built.  

Its a little confusing because two subtly different things share the
same name - a plain old C shared library, and a ruby extension that
uses it.  It's the latter part that is being complained about in those
error messages.

Try rebuilding now that you have the -dev package installed, and see
if that helps.

Note that you'll probably find that other extensions bundled with the
interpreter are missing if you don't have the requisite -dev packages
when you build.

--
Stephen Lewis