On Dec 27, 10:37 am, yudi <yudi.... / gmail.com> wrote:
> [Note:  parts of this message were removed to make it a legal post.]
>
> I did, quite a few times.
>
> On Dec 27, 2007 3:30 AM, Han Kessels <han.kess... / gmail.com> wrote:
>
>
>
> > On Dec 27, 11:57am, Tadatoshi Takahashi <tadato... / gmail.com> wrote:
> > > On Dec 26, 9:42 pm, Raul Parolari <raulparol... / gmail.com> wrote:
>
> > > > Tadatoshi Takahashi wrote:
> > > > > After I modified support/shobj-conf for readline following Han's
> > > > > instruction, the problem still persists.
>
> > > > There were 2 different corrections to the problem:
> > > > 1) generate readline in the way indicated by Yudi (..make
> > > > static-install) above
> > > > 2) correct the test on the OS version as indicated by Han.
>
> > > > I am still using MacOsX 10.4.11, and I cannot confirm that the 2
> > actions
> > > > fix the problem for Leopard. But they (in my case, just the first
> > alone)
> > > > allowed me to (finally..) generate ruby 1.9.
>
> > > > I wrote this just in case you overlooked the first correction.
>
> > > > And by the way, thanks to Yudi and Han
>
> > > > Raul
> > > > --
> > > > Posted viahttp://www.ruby-forum.com/.
>
> > > Thank you for your reply, Raul.
>
> > > Actually, just to install readline itself required the first
> > > correction.
> > > Then I went on to execute make for Ruby 1.9.
> > > At that time, I got the same error as James originally posted.
> > > So I followed Han's instruction.
> > > But the problem still persisted.
> > > (I'm using Mac OS X 10.5.1 Leopard.)
>
> > Once you succeeded in installing readline in /usr/local, did you point
> > ruby1.9 at it?
> > ./configure --prefix=/usr/local/ruby1.9 --with-readline-dir=/usr/local
>
> --
> Do not be afraid of Change.

Thank you for your reply, Han.

Yes, I did as well.
In my case, just like Yudi, ./configure --prefix=/usr/local --with-
readline-dir=/usr/local