On Dec 27, 2:29 pm, Snoop1990 Snoop1990 <snoopy1... / googlemail.com>
wrote:
> Frederick Cheung wrote:
> > On 27 Dec 2007, at 17:18, Snoop1990 Snoop1990 wrote:
>
> >> copy/vendor/rails/railties/lib/commands/server.rb:39
> >>  from ./script/server:3:in `require'
> >>  from ./script/server:3
>
> > This app has gems frozen in vendor
>
> >>  from ./script/../config/boot.rb:18
> >>  from ./script/server:2:in `require'
> >>  from ./script/server:2
>
> > This one probably doesn't. Do you have rubygems installed ?
>
> > Fred
>
> As you see in the posts above the Application created on Linux works on
> Linux only the one created on FreeBSD and then transfered to a Linux
> server does not work !

This work? (inside a irb session):

require 'rubygems'
=> true

If that is the answer, then something is wrong in other place, but if
it raise a LoadError exception, that means you don't have rubygems
installed and that is part of config/boot.rb

HTH,

Luis