On Dec 27, 12:04 pm, Rick DeNatale <rick.denat... / gmail.com> wrote:
>
> Keep in mind that Ruby 1.9 is really a new language,  Matz and co
> decided to release it as a way of driving towards Ruby 2.0 whose
> version number would more clearly indicate this, but there are changes
> in 1.9, which are deliberately incompatible with Ruby 1.8.  Matz has
> spent the past few months backing out some of the more radical
> experimental changes, but there's no guarantee of backward
> compatibility.
>

Exactly, 1.9.0 was labeled a "development" release, not a stable, not
the replacement for 1.8 from day zero, will take longer to achieve
that goal.

> Some of us have been keeping an eye on the evolution of 1.9 for some
> time before 1.9.0 we've been the scouts, with 1.9.0 we're starting to
> see more early adopters, or pioneers, start the journey to Ruby 2.0.
> The danger is unwitting pioneers won't have gotten the message about
> the role of 1.9 in relation to 1.8 (and 2.0) and will load up their
> Conestoga wagons without realizing the real possibility of getting
> arrows in their back.
>
> What concerns me is that I'm seeing postings from folks, not only
> here, but places like the Textmate mailing list, who have installed
> Ruby 1.9 from source, and found that existing code using, and
> expecting the ruby command to map to Ruby 1.8 is breaking.
>

The problem is that these users don't read things, don't research a
bit before start playing with loaded guns, they didn't read the
_development release_ label matz put on his announcement.

> I posted a suggestion to ruby-core that perhaps the Ruby 1.9 tarball
> should be set up so that BY DEFAULT, it installs as ruby1.9 instead of
> ruby, so that unwitting installers don't get their Ruby1.8
> installation replaced by default.

Users experimenting with installation from source should be aware of
these risks. Is not Ruby responsibility to "babysit" all the users and
avoid they shoot their foot.

What you requested will also require a "new" release of 1.9.0-0, (note
the zero of patchlevel), and I think is too early to do it (the
complexity and because matz, ko1 and others need to relax a bit).

-
Luis Lavena