Ryan Davis wrote:
> 
> On Dec 24, 2007, at 12:10 , Pokkai Dokkai wrote:
> 
>>  i tried to install 'stringio' and some related package
>> (by synaptic package manager in ubuntu7.04) .
>>
>> but can't get corresponding package to solve above error.
> 
> this is _precisely_ why I won't use ubuntu for ruby development.
> 
> what an f'in PITA.

There's no need to reference unspeakable acts with middle-eastern 
flatbreads, or any baked good.

A simple rule for happiness: build ruby from source, and let it go in 
/usr/local (or anywhere but /usr). For the developer, that has the 
advantage, on any OS, of (a) letting you tinker with the interpreter and 
(b) building with architecture-specific optimizations.

Use apt-get (or whatever) to get the few dependencies that are not 
commonly installed (such as readline), or build them yourself.

-- 
       vjoel : Joel VanderWerf : path berkeley edu : 510 665 3407