On Dec 24, 3:16 pm, Li Chen <chen_... / yahoo.com> wrote:
> Luis Lavena wrote:
>
> ,
>
>
>
> > I don't own or have a Vista system to recreate your situation, could
> > you copy the output you get running "gem env" from outside c:\ruby\bin
> > folder? also, which version of rubygem you're using will be helpful
> > too.
>
> > Regards,
>
> > Luis
>
> Hi Luis,
>
> Here is what I get from the prompt window.
>
> Thanks,
>
> Li
>
> ###############################################
>
> C:\Users\Alex>gem env
> :1: no such file to load -- rubygems (LoadError)
>
> C:\Users\Alex>ruby --version
> ruby 1.8.6 (2007-09-24 patchlevel 111) [i386-mswin32]
>
> C:\Users\Alex>ruby -v
> ruby 1.8.6 (2007-09-24 patchlevel 111) [i386-mswin32]
>
> C:\Users\Alex>gem --version
> :1: no such file to load -- rubygems (LoadError)
>
> C:\Users\Alex>cd\
>
> C:\>cd ruby\bin
>
> C:\ruby\bin>ruby --version
> ruby 1.8.6 (2007-09-24 patchlevel 111) [i386-mswin32]
>
> C:\ruby\bin>gem env
> RubyGems Environment:
>   - RUBYGEMS VERSION: 1.0.1 (1.0.1)
>   - RUBY VERSION: 1.8.6 (2007-09-24 patchlevel 111) [i386-mswin32]
>   - INSTALLATION DIRECTORY: C:/ruby/lib/ruby/gems/1.8
>   - RUBY EXECUTABLE: C:/ruby/bin/ruby.exe
>   - RUBYGEMS PLATFORMS:
>     - ruby
>     - x86-mswin32-60
>   - GEM PATHS:
>      - C:/ruby/lib/ruby/gems/1.8
>   - GEM CONFIGURATION:
>      - :update_sources => true
>      - :verbose => true
>      - :benchmark => false
>      - :backtrace => false
>      - :bulk_threshold => 1000
>   - REMOTE SOURCES:
>      -http://gems.rubyforge.org
>
> C:\ruby\bin>gem --v
> ERROR:  Invalid option: --v.  See 'gem --help'.
>
> C:\ruby\bin>gem --version
> 1.0.1
>
> C:\ruby\bin>
>

Can you list the contents of c:\ruby\bin\ ?
I'm interested to see if there are other extensions for gem (looking
for .cmd or .bat files) and their contents.

I'm not familiar with the error message you're getting. could you do
the following steps and copy your output?

=====

D:\Users\Luis>set RUBYOPT
Environment variable RUBYOPT not defined

D:\Users\Luis>SET RUBYOPT=rubygems

D:\Users\Luis>ruby -v
ruby 1.8.5 (2007-09-24 patchlevel 114) [i386-mswin32]

D:\Users\Luis>irb
irb(main):001:0> require 'rubygems'
=> false

===

Will be handy to know if you have administrative privileges or not
(since UAC is a big pain).

Regards,

Luis