I had the same problem.

Try installing the latest Xcode 3.0 tool set.
This worked for me.

Cheers.


John Ta wrote:
> Hi,
> I'm having the same issue as well.
> 
> Leopard 10.5 and trying to install 0.11.4 Ferret.
> 
> 
> 
> 
> Levent Ali wrote:
>> Can anyone shed light on why this is happening?
>> It happens with ferret 0.11.4 and 0.11.5
>> 
>> I installed ferret 0.11.3 without any hiccups before the recent release
>> of OS X 10.5.1
>> 
>> Select which gem to install for your platform (i686-darwin8.10.3)
>>  1. ferret 0.11.5 (mswin32)
>>  2. ferret 0.11.5 (ruby)
>>  3. ferret 0.11.4 (ruby)
>>  4. ferret 0.11.4 (mswin32)
>>  5. Skip this gem
>>  6. Cancel installation
>>> 2
>> Building native extensions.  This could take a while...
>> ERROR:  While executing gem ... (Gem::Installer::ExtensionBuildError)
>>     ERROR: Failed to build gem native extension.
>> 

-- 
Posted via http://www.ruby-forum.com/.