On Dec 19, 3:06 pm, "Jack Johnson" <jjohn... / cyberworlds.com> wrote:
> Hi, all -
>
> There are a number of gems that I can't get to install native versions on
> Windows XP, including win32-api 1.0.5, win32-service 0.6.0, fastthread, and
> mongrel_service. Every attempt to install produces an attempted compilation
> which fails as I don't have Visual Studio 2003 installed. I see this same
> incorrect behavior with rubygems 0.9.4 and 0.9.5. (I've updated to Rails
> 2.0.2, which necessitated updating to rubygems 0.9.5. I'm running ruby 1.8.6
> patchlevel 111.)
>
> Other gems have installed their native versions with no problem.
>
> Can anybody point me in the right direction?
>

Jack, you should have searched for this topic before posting:

- Current RubyGems 0.9.5 is broken for native platform like mswin32.
- Gems created with 'mswin32' platform will fail.
- Eric and other rubygems developers are working on fix this for
upcoming release of RubyGems, but didn't make it available (you can
checkout the svn repository)
- Rails 2.0.2 gems are broken against 0.9.4 (not backward compatible).
They should have forced a pure ruby (RUBY) platform in their gems
instead of leaving it blank.

I cannot help you on that road, the Rails guys should be aware of this
situation and they must have plans to fix this (at least I hope so).

Luis