On Dec 12, 1:26 pm, Alex DeCaria <alex.deca... / millersville.edu>
wrote:
> I am currently using Ruby 1.8.21 on a Windows machine.  I want to
> upgrade to a newer version.  Do I need to uninstall the current version
> of Ruby before using the 1-click installer, or can I just go ahead and
> run the 1-click installer?

I'll suggest you uninstall that first, mostly due the changes
introduced in latest versions.

Another workaround will be install it on a different location (C:\Ruby
instead of C:\Program Files\Ruby).

Or C:\Ruby186

The versioning of One-Click installer is confusing: the latest version
is 26, which is 1.8.6 patchlevel 111 (that's the reported ruby
version).

HTH,

Luis