> Can't install gosu by 'gem install gosu' it asks me the version I want
> to install, I select the latest and then it gives me error 'Permission
> denied - /usr/local/lib/ruby/gems/1.8/cache/gosu-0.7.8-universal-
> darwin-8.gem' what to do?

On OS X, you need to call it as 'sudo gem install gosu'.