Venks wrote:
> According to the information here, pure Ruby MySQL doesn't work with
> 4.1 or 5.x. If that's true, I am not sure if pure Ruby MySQL is of any
> use.
> 
> http://wiki.rubyonrails.org/rails/pages/MySQL

That's unusual, since rails works fine with the pure-ruby mysql driver. 
However, if you're looking to use mysql directly, perhaps you should 
look into using JDBC instead? I'm sure we can find a good example if 
you're interesed in that. JDBC provides a uniform interface to basically 
any database.

- Charlie