On Dec 5, 7:08 am, Vassilis Rizopoulos <damp... / freemail.gr> wrote:
> Is there a binary gem for fastthread on windows?
>

Yes, there is.

RubyGems 0.9.5 is broken for mswin32.

This was reported here, in mongrel mailing list and all over the web.

> gem install fastthread on windows tries to compile with rather
> unpleasant consequences.

gem install is trying to install the ruby version of all these gems
since "think" there is no match for 'mswin32' platform.

All that was fixed on RubyGems trunk but still no official release of
"0.9.5.1" to fix it.

> I guess fastthread compilation is done with the VC6.0 tools, cause my
> VS2005 installation crashes and burns:
>

You can use a different compiler than the one use to build ruby. You
need to build ruby with VS2005.

That's another story, the bottom line is: rubygems shouldn't be asking

Revert to RubyGems 0.9.4 for the time being and this problem will go
away.

(I know is not your fault, but I'm really getting tired of repeat
myself all over again).

HTH,

Luis