David A. Black wrote:
> Reserved words can still be method names (e.g., class). It would be
> nice to have a different word for this method, since it does feel a
> bit backwards in relation to the other "yield", but as I recall there
> have been discussions already and nothing that Matz liked was
> proposed.

I think the documentation of the method should be a little bit extended. 
The name of the method is not as bad as it looks like in the first 
moment, because it is used in the way to "yield" a value later to the 
user of the generator.

After yours and  Jordan's explanations everything is clear now. It's 
simply the documentation text "Yields an element to the generator", 
which leads to the assumption, that the method can be called elsewhere 
and delivers some objekt to the existing generator.

Wolfgang NĂ¡dasi-Donner
-- 
Posted via http://www.ruby-forum.com/.