Hi comp.lang.ruby

I am doing my first thing with ActiveRecord (without Rails), and to
help me out I have the 'Pro ActiveRecord' book from APress, which is a
fine resource, except from one annoying thing; all pieces of sample
code in the book uses the statement:

  require 'activerecord'

which refuses to work on both my windows-ruby and ubuntu-ruby setups.
Searching this group I learned that using the statement:

  require 'active_record'

solves that problem. What am I missing? What's the difference between
the two, and why is only one of them working on my code?


regards, henning