On Nov 29, 2007, at 15:25 PM, Eric Smith wrote:
> Eric Hodel wrote:
>> On Nov 28, 2007, at 04:53 AM, Austin Ziegler wrote:
>>> On 11/27/07, Eric Hodel <drbrain / segment7.net> wrote:
>>>> At that point, RubyGems is doing the equivalent of:
>>>>
>>>> ruby -e "require 'openssl'"
>>>>
>>>> I'm researching why RubyGems now seems to require OpenSSL, but
>>>> haven't
>>>> discovered the cause yet.
>>>
>>> Signed gems are done with SSL.
>>
>> This appears to be happening regardless of signing of gems.
>
> The problem is that the default installation of ruby 1.8.6 from source
> isn't picking up the OpenSSL libraries, etc... during make or make
> install.

No.

RubyGems should work with or without OpenSSL.  If RubyGems is not  
working when you don't have OpenSSL, it's a RubyGems bug.