On Nov 26, 5:28 pm, Rit Li <kimrith... / gmail.com> wrote:
> The ruby from Ubuntu's repository is 1.8.6 patch 36.
>
> So I download the 1.8.6 p111 source and:
>
> /configure
> make
> make install
>
> I have ruby 1.8.6 p111 installed. However, I got some loaderror like
> readline...
>

1st: uninstall the ruby version that came with ubuntu. This is
important since both ruby installation clash (it happened to me but I
don't remember right now).

2nd: sudo apt-get build-dep ruby1.8 (to grab all the needed
dependencies to compile ruby).

3rd: NOW you can compile ruby.

HTH,