HoboHoward <hobohoward77 / yahoo.com> writes:
> Dear List,
>
> I want to install hpricot on my Solaris x-86 box.
>
> The makefile generated by the hpricot-installer wants me to use the
> 'cc' c-compiler.
>
> I dont have 'cc'.
>
> I have 'gcc'.
>
> Is it possible for me to force the hpricot-installer to use my copy of
> gcc ??

It really wants to use the compiler that Ruby was built with.

[~]0% ruby -rrbconfig -e 'p Config::CONFIG["CC"]'
"cc"

The Sun compiler suite can be downloaded for free, but if you are
really attached to gcc then you should build Ruby yourself instead of
using blastwave.

Steve