Arto Kalishian wrote:
> I have problems running the latest Ruby 1.8.6 on Windows Vista, and this
> is (my guess) due to permission problems.
> 

Maybe.  I've been using Ruby on Vista Home for about 2 months now.  Poor 
Ruby support is not among my many reasons to dislike Vista.

OTOH, I disabled (as best I could) the annoying Please Ask Permission 
stuff early on.

> I loved Ruby from first sight to the point that I started to hate VB
> 2005 Express. But VB Express 2005, is to my dissapointment much more
> compatible and easier to use on Windows Vista than Ruby. 

Well, what you're experiencing is  perhaps Scite+Ruby on Vista.

I'd suggest getting comfortable with doing things at the command line 
(even if you prefer a IDE-like editor).


> So I beg of you
> tell me of a clean and neat way to install Ruby on Vista without
> encountering problems. Thanks, arto
> 
> ================
> require ' yaml' # Told you it was easy.

-----------^ misplaced whitespace!

> 
> test_array = [' Give Quiche A Chance' ,
> ' Mutants Out!' ,
> ' Chameleonic Life-Forms, No Thanks' ]
> 
> # Here' s half of the magic:
> 
> test_string = test_array.to_yaml
> 
> # You see? Kind of like "to_s", and it is in fact a string,
> # but it' s a YAML description of "test_array".
> 
> filename = ' RimmerTShirts.txt'

--------------^ misplaced whitespace?

> File.open filename, ' w' do |f|

-----------------------^ misplaced whitespace!


Are you cutting and pasting from someplace that is padding the clipboard 
text?  You have a lot of quoted strings with a leading space.




-- 
James Britt

"If you don't write it down, it never happened."
  - (Unknown)