------art_993_16907040.1195984416488
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 7bit
Content-Disposition: inline

Feng,
Check your Cygwin installation and make sure you have gcc installed. It's
under compilers or something like that. It seems that the line that's
throwing the error is

make gcc: Command not found

I have a somewhat limited experience with Ruby, Windows XP and Cygwin but I
remember that a gem installed from the Windows command line will work in
Cygwin too (at least it's present when I issue a `gem list`)

On 11/25/07, Feng Tien <pood.forums / gmail.com> wrote:
>
> I'm trying to run scRUBYt on winXp, but found out it just doesn't work.
>
> So the work around is to use cygwin.
>
> I'm trying to install Hpricot
>
>
> I keep on getting this error:
>
> 
> ERROR:   Error installing hpricot:
>          ERROR: Failed to build gem native extension.
>
> /usr/bin/ruby.exe extconf.rb install hpricot
> checking for main() in -lc...no
> creating Makefile
>
> make gcc -I. -I. -I/usr/lib/ruby/1.8/i386-cygwin -I. -g -02   -c
> hpricot_scan.c
> make gcc: Command not found
> make: *** [hpricot.scan.o] 127
>
> >
>
> I've installed FlexMock using gems just fine in cygwin, so what's wrong?
>
> When trying to install Mechanize, I get the exact same message, can't
> make hpricot.
> --
> Posted via http://www.ruby-forum.com/.
>
>


-- 
Andrei Maxim
http://andreimaxim.ro

------art_993_16907040.1195984416488--