On Wed, 21 Nov 2007 10:28:03 -0500, Austin Ziegler wrote:
> Fact set two: Debian (1) modified RubyGems; (2) didn't submit any
> patches; (3) made a particularly stupid modification; and (4) provided
> nothing to help users upgrade RubyGems externally of the Debian
> packages.

If you think that being able to upgrade RubyGems externally of the Debian 
packages is a good thing, then you don't understand the philosophy of a 
Linux package manager, and you deserve whatever breakage results from 
your stubborn insistence on flouting the package manager.

gem update --system should be removed from distribution-provided packages.

--Ken

-- 
Ken (Chanoch) Bloom. PhD candidate. Linguistic Cognition Laboratory.
Department of Computer Science. Illinois Institute of Technology.
http://www.iit.edu/~kbloom1/