On 23 Nov 2007, at 04:47, Jeremy Mclain wrote:

> I love the flexibility of writing scripts in Ruby but my work doesn't
> allow me to install the Ruby interpreter on my system.

Why (he asks curiously)? Any way of addressing that problem directly?

> Does anyone know
> of any tools that will translate my Ruby scripts into Perl scripts?

Ask them to install the CPAN Inline::Ruby module and see if they  
accidentally install Ruby as a dependency :-)

>   My
> Ruby scripts aren't "Perlish" so it is not a trivial task to do it
> manually.

What kind of things are causing problems?

>   I know the frameworks are different and I can deal with that.
> I mostly only care about the syntactic translation.  Any suggestions?

There's nothing like a Ruby->Perl compiler that I'm aware of. Which  
bits of Ruby syntax are do you like most? It might be easier to pick  
some useful modules (e.g. Moose for OO) and stick with Perl. It  
doesn't have to look completely evil :)

Cheers,

Adrian