On Nov 19, 2007, at 21:53 , Michael Greenly wrote:

> I got caught by some "tired at the end of the day" stupidity...
>
> I was using the Ubuntu (apt-get installed) package of RubyGems.  Go
> figure if you do a 'gem update --system' in this situation it makes a
> mess of things.
>
> I choose to try gems out this way because every time I've installed  
> Gems
> from source to some prefix other than /usr/lib  it's managed to find
> some way to not work or be otherwise inconvenient.
>
> RubyGems has really become the one thing about Ruby I dislike.

Rather than using features provided by RubyGems (GEM_PATH), Debian  
(and I guess also Ubuntu since it also uses apt) instead chose to  
hack RubyGems.

If this causes breakage, I'm sorry, but it is impossible for the  
RubyGems team to support a hacked RubyGems.

--
Poor workers blame their tools. Good workers build better tools. The
best workers get their tools to do the work for them. -- Syndicate Wars