On Nov 14, 8:28 pm, Greg Weeks <greg.we... / arm.com> wrote:
> In all of the code below, "prock" by itself is always a proc, while the
> combination "&prock" is always a block:
>
>     def my_proc &prock    # accepts a block
>       prock               # returns a proc
>     end
>
>     prock = my_proc { p "Hello, world" }
>
>     prock.call
>
>     def doit &prock  # param is redundant, but illustrative
>       yield             # yields to &prock, a block
>     end
>
>     doit &prock         # same as 'doit { p "Hello, world" }'
>
> So, it seems to me that "prock" above is distinctly clearer than
> "block".  ("proc" would be better still, but it's taken.)
>
> My only problem with "prock" is that my eye tends to scan it as p-rock
> instead of the desired proc-k.  But it still seems better than "block".
> Any other ideas?  "proce" perhaps?  "procc"?

use something more semantically relevant when you can:

  &action
  &event
  &what_i_do_on_wednesdays

T.