Raul,
Thanks the reply.  Before I got your reply, I installed the DBI package 
so that I could write Ruby scripts that access MySQL databases.  When I 
attempt to run a test script, I get the
following error:

/usr/local/lib/site_ruby/1.8/dbi.rb:344:in `load_driver': Could not load
driver (no such file to load -- mysql) (DBI::InterfaceError)
        from /usr/local/lib/site_ruby/1.8/dbi.rb:227:in
`_get_full_driver'
        from /usr/local/lib/site_ruby/1.8/dbi.rb:213:in `connect'
        from /root/bin/simple.rb:6

I used the instructions at this link:

www.kitebird.com/articles/rubi-dbi.html

I noticed you mentioned something about one step you mentioned not being 
clear in the kitebird article, do you think that might be my problem? 
If not, do you have any idea how I'd go about figuring out what the fix 
for this error is?
Thanks again,
PV




Raul Parolari wrote:
> Peter Vanderhaden wrote:
>> I've just downloaded the DBI for MySQL.  I have Ruby installed on my
>> Ubuntu system, but I don't know how to install the DBI package.  (I'm
>> new to Linux)  Can someone give me a step-by-step list on how to do it,
>> including how to unzip the tar.gz file?  I'd really appreciate the help.
> 
> Peter (welcome to Unix, by the way)
> 
>    I am not an expert on this, but I had to do it (on a Mac) and I can 
> help.
> 
> Let me tell you that you picked up to start on Linux an installation 
> that is not the easiest because of 3 layers of interdependency between 
> components. But if you have a bit of pacience, it should work (all other 
> installations that you will need to do will be a piece of cake after 
> this).
> 
> First: there are 3 components to be able to work with the Ruby DBI, that 
> you should install in this order (I assume you have a recent Ruby 
> version installed):
> 
> 1) install MySql (5.0 or later); this will generate something called the 
> "MySql C Client Api" (I mention it as you will find references to it).
> 
> 2) install the Ruby-MySql module, from 
> http://www.tmtm.org/en/mysql/ruby.
> This is a MySql Ruby Client Api (a wrapper around the MySql C client Api 
> mentioned above). This install will provide the DRIVER (mysql.rb).
> 
> [Note: this installation failed this June on my Mac because of a missing 
> C ulong define, that one has to write manually (!). I don't think the 
> problem exists on Linux].
> 
> 3) finally install the Ruby-Dbi module which will use the Driver 
> installed in previous point. The best doc (all others on the web give 
> you only part of the story) is 
> http://www.kitebird.com/articles/ruby-mysql.html, written by Paul Du 
> Bois (MySql guru). He even shows how to untar (the equivalent of what 
> you called 'unzip') the distribution. The only thing not clearly 
> described in his document is step 2 above.
> 
> 
> Of course, if somebody knows a simpler way, please let us know; in the 
> meantime, the above works.
> 
> Good luck
> Raul

-- 
Posted via http://www.ruby-forum.com/.