kendear wrote:
> On 10/30/07, mortee <mortee.lists / kavemalna.hu> wrote:
>>
>> C:\>gem list hpricot
>>
>> *** LOCAL GEMS ***
>>
>> hpricot (0.6, 0.5, 0.4)
>>     a swift, liberal HTML parser with a fantastic library
>>
>> C:\>irb
>> irb(main):001:0> require 'hpricot'
>> => true
>> irb(main):002:0> d = Hpricot("<b>hello <i>world</i></b>")
>> => #<Hpricot::Doc {elem <b> "hello " {elem <i> "world" </i>} </b>}>
>> irb(main):003:0> d.inner_text
>> => "hello world"
>>
>> mortee
>>
>>
>>
> yup, mine is
> 
> C:\>gem list hpricot
> 
> *** LOCAL GEMS ***
> 
> hpricot (0.4)
>     a swift, liberal HTML parser with a fantastic library
> 
> and d.inner_text or d.text both won't work.
> 

Does something prevent you from upgrading?

mortee