Hi,

Re-installed Rails and am getting new error as mentioned in item 3 
below:

---------------
1. found use_ruby.cmd in C:\InstantRails-1.7-win\InstantRails dir
   ran the cmd from console, as:

C:\InstantRails-1.7-win\InstantRails>use_ruby.cmd

C:\InstantRails-1.7-win\InstantRails>CD 
C:\InstantRails-1.7-win\InstantRails

C:\InstantRails-1.7-win\InstantRails>PATH 
C:\InstantRails-1.7-win\InstantRails\ruby\bin;C:\InstantRails-1.7-win\InstantRails\mysql\bin;C:\or
acle\product\10.2.0\client_1\bin;C:\WINDOWS\system32;C:\WINDOWS;

C:\InstantRails-1.7-win\InstantRails>cd rails_apps

C:\InstantRails-1.7-win\InstantRails\rails_apps>dir
 Volume in drive C is WINXP
 Volume Serial Number is 9897-F09E

 Directory of C:\InstantRails-1.7-win\InstantRails\rails_apps

10/30/2007  03:22 PM    <DIR>          .
10/30/2007  03:22 PM    <DIR>          ..
10/30/2007  03:22 PM    <DIR>          .metadata
10/30/2007  03:22 PM    <DIR>          cookbook
10/30/2007  03:22 PM    <DIR>          typo-2.6.0
               0 File(s)              0 bytes
               5 Dir(s)  43,133,116,416 bytes free

---------------------------
2. found gem sources-** in 
C:\InstantRails-1.7-win\InstantRails\ruby\lib\ruby\gems\1.8\doc\rubygems-0.9.2\rdoc\classes\Gem


3. Ran the update
   gem update --system

get the following error:
C:\InstantRails-1.7-win\InstantRails\rails_apps>gem update --system
Updating RubyGems...
ERROR:  While executing gem ... (Gem::RemoteFetcher::FetchError)
    Bad file descriptor - connect(2)(Errno::EBADF)

---------------
Thanks.
Ron.



Ronald Dsouza wrote:
> Hi Mohit/Roger
> Thanks for your response
> After I sent the message I just un-installed everything and am
> redoing unzipping to a new dir C:/InstantRails-1.7-win.
> 
> then I am planning to run tests as you have mentioned.
> 
> will keep you posted on this forum regarding the progress.
> 
> Thanks again.
> Ron.
> 
> Roger Pack wrote:
>> make sure gems/sources-x-x directory exists
>> maybe edit rbconfig.rb ('s) that exist, point them to your directory
>> where you installed it.
>> 
>>> 
>>> C:/ruby/InstantRails-1.7-win/InstantRails/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in
>>> `gem_original_require': no such file
>>> to load -- sources (LoadError)

-- 
Posted via http://www.ruby-forum.com/.