Hi Good Morning,
I downloaded and installed the Instant Rails 1.7 from the website
onto my local windows xp machine in
C:\ruby\InstantRails-1.7-win\InstantRails

then I ran the following to update the version of RubyGems that comes
with InstantRails:
C:\InstantRails> gem update --system

I get the following error: (could someone help me where I am going
wrong)
thanks.

C:/ruby/InstantRails-1.7-win/InstantRails/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in
`gem_original_require': no such file
to load -- sources (LoadError)
        from
C:/ruby/InstantRails-1.7-win/InstantRails/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in
`require'
        from
C:/ruby/InstantRails-1.7-win/InstantRails/ruby/lib/ruby/site_ruby/1.8/rubygems/source_info_cache.rb:6
        from
C:/ruby/InstantRails-1.7-win/InstantRails/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in
`gem_original_require'
        from
C:/ruby/InstantRails-1.7-win/InstantRails/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in
`require'
        from
C:/ruby/InstantRails-1.7-win/InstantRails/ruby/lib/ruby/site_ruby/1.8/rubygems/remote_installer.rb:12
        from
C:/ruby/InstantRails-1.7-win/InstantRails/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in
`gem_original_require'
        from
C:/ruby/InstantRails-1.7-win/InstantRails/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in
`require'
        from
C:/ruby/InstantRails-1.7-win/InstantRails/ruby/lib/ruby/site_ruby/1.8/rubygems.rb:112:in
`manage_gems'
        from
C:/ruby/InstantRails-1.7-win/InstantRails/ruby/bin/gem.bat:6
-- 
Posted via http://www.ruby-forum.com/.