On Oct 22, 2007, at 11:29 , redroofgreentree wrote:

> Hey,
>
>   So I'm trying to get ruby gems to work, and am stuck on the  
> following:
>
> $ gem contents ruby-debug; gem env; ls -d /var/lib/gems/1.8/gems/ruby-
> debug-0.9.3/
> Unable to find gem 'ruby-debug' in default gem paths
> Rubygems Environment:
>   - VERSION: 0.9.0 (0.9.0)
>   - INSTALLATION DIRECTORY: /var/lib/gems/1.8
>   - GEM PATH:
>      - /var/lib/gems/1.8
>   - REMOTE SOURCES:
>      - http://gems.rubyforge.org
> /var/lib/gems/1.8/gems/ruby-debug-0.9.3/
>
>
> This doesn't seem to make sense to me .... it can't find ruby- 
> debug, but the
> folder is clearly in the gem env path ... can someone please tel  
> lme what
> I'm doing wrong? (running on Ubuntu; stock ruby/ems installation)

Is there a ruby-debug-0.9.3.gemspec?  It would be in the  
specifications dir next to the gems dir.

--
Poor workers blame their tools. Good workers build better tools. The
best workers get their tools to do the work for them. -- Syndicate Wars