On Oct 23, 2007, at 8:57 AM, Surjit Nameirakpam wrote:

> I wanted to read a csv file and do some manipulation on it so i tried
> writing a small program  but i get this error
>
> ##########T his is the program
>
> require "faster_csv"
>   FasterCSV.foreach("C:\\rubyprograms\\Input.csv") do |row|
>     # use row here...
>   puts row
>   end
> ########## This is the error
>
> trialread.rb:1:in `require': no such file to load -- faster_csv
> (LoadError)
>         from trialread.rb:1
>
> Please help on what mistake i am commiting

Have you installed FasterCSV?  If so, you are probably just missing:

   require "rubygems"

at the top of your file.

James Edward Gray II