On 10/7/07, ara.t.howard <ara.t.howard / gmail.com> wrote:
>
> On Oct 7, 2007, at 3:21 AM, Eric Hodel wrote:
>
> > I don't know if the name #sort_obj is appropriate, but I'm not
> > coming up with something better.
>
> i prefer #order, #order_by since the concept is extends to much more
> that sorting, for instance iterating or returning elements from a
> collection such as a priority queue.  in any case the idea is a good
> one.

 its a great idea and i have been using it for years in sql by the
name "sortkey" although after reading ara's point i think i prefer the
term "orderkey" now.
another name in collation docs is "weight string".  i think i like
weight_string the best because it is less verby and confrontational
than order_by and order.  both of these are sort of "in your face"
sounding.  cheers,
-r.