On Oct 7, 7:42 am, "David A. Black" <dbl... / rubypal.com> wrote:
> I think Eric intends it to return a kind of sort key, not to actually
> specify the sorting algorithm.

I realize. But clearly a standard definition of <=> would be based on
it. So the "coupling" method of Sortable could be #sort_key instead of
#<=>, though of course one can still override #<=> if need be.

> > Perhaps a better name is #indice or #sort_index, or something like
> > that.
>
> I'm afraid "indice" isn't a word :-) The singular of indices is index.

Ah, well. I'm an American; dropping 's' is good enough for me ;)
#sort_key is a perfectly good name.

T.