Trans wrote:
> On Oct 1, 2:05 pm, Eric Hodel <drbr... / segment7.net> wrote:
>>
>> install a gem.cmd, but either it wasn't, or gem.bat gets picked over
>> gem.cmd automatically.
>>
>> The install failed, and you don't have /path/to/ruby/site_ruby/
>> <version>/rubygems/gem_runner.rb
>>
>> There is some other bug in gem_runner that gave a syntax error, so
>> svn up and try again.
>>
>> Something else is wrong with your machine.
> 
> Hmmm... okay, since I upgraded from 0.9.2 (from OneClickInstaller) to
> 0.9.4 using setup.rb and then the same with trunk I'm assuming the
> first reason you mention. I''d delete the whole shebang and try
> reinstalling.
> 
> T.

One-Click-Installer (OCI) encapsulates the gem gemwhich and the other 
rubygems scripts into .cmd files (and remove the plain scripts).

When you install rubygems from source (setup.rb) it creates the gem 
scripts and also the stubs .bat <-- note the different extension from 
.cmd.

On XP/2000 platforms, .cmd is preferred over .bat files, so the old 
script get run instead of the new one.

Just remove the .cmd files that match existing .bat from Ruby\bin and 
guess that could work for you.

(In case you solved the no-connection-to-internet shown before)

HTH,

Luis
-- 
Posted via http://www.ruby-forum.com/.