could be  a PATH issue.
make sure it's installing to the right Ruby.
If you used the Hivelogic method to install stuff, you will still  
have the old broken Ruby on your system.
Also if you've installed anything else (Python for example) your path  
might have changed.
there is also a gem path, but I don't recall the details, check the  
docs at rubygems.org